Programmation iOS 5.1 et Snow Leopard / Lion

de | 13 mars 2012

Xcode et Mac Os Lion / Snow Leopard

Un petit article rapide pour vous informer qu’il est maintenant impossible (ou presque) d’utiliser XCode avec le SDK iOS 5.1 sous Snow Leopard.

En effet, si vous avez migrez vos appareils Apple iOS (iPhone, iPod, iPad) en version 5.1, vous vous êtes aperçus que vous ne pouvez plus les utiliser pour programmer avec Xcode et tester vos applications. En effet, XCode demande la dernière version du SDK iOS (le 5.1), mais celle-ci n’est pas disponible pour Mac OS X Snow Leopard.

Vous n’avez donc pas beaucoup de solution si ce n’est acheter la mise à jour version la nouvelle version de Mac Os X : Lion (10.7.3 actuellement). Celle-ci vous en coutera 23,99€ (ce qu’on peut qualifier de raisonnable). Petit coup de gueule contre Apple qui force ainsi tous les développeurs à migrer sous Lion et à vérifier que tous leurs outils fonctionnent bien sur cet OS.

Il existe une autre solution plus périlleuse qui consiste à recopier des fichiers du SDK 5.1 installé sur un Os Lion pour les copier sur Snow Leopard. Mais nous n’avons pas tenter cette opération qui nous semble un peu risquée.

Une fois Mac OS Lion installé, vous pourrez installer XCode depuis le Mac App Store ce qui vous fera bénéficier des mises à jour automatiques comme c’est déjà le cas avec les autres logiciels.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.